skip to content »

arisufit.ru

Config files in etcportage need updating

config files in etcportage need updating-69

Would you like to add these changes to your config files? calculate ~ # etc-update Scanning Configuration files...

config files in etcportage need updating-52config files in etcportage need updating-5config files in etcportage need updating-75config files in etcportage need updating-74

However, it is also possible that conflicting dependencies exist such that they are impossible to satisfy simultaneously.I am going to try and stay very basic here so you can get the idea.Fresh install and everything is working great so now what? If you like nano you can simple go into Konsole and punch in su than enter your password.funtoo rj # emerge -pv gentoolkit portage These are the packages that would be merged, in order: Calculating dependencies... [ebuild R ] sys-apps/portage-2.4.1::gentoo USE="(ipc) xattr -build -doc -epydoc (-selinux)" LINGUAS="-ru" PYTHON_TARGETS="python2_7 python3_4 -pypy -python3_3 -python3_5" 0 Ki B [ebuild R ] app-portage/gentoolkit-0.3.1::gentoo PYTHON_TARGETS="python2_7 python3_4 -pypy -python3_3 -python3_5" 0 Ki B Total: 2 packages (2 reinstalls), Size of downloads: 0 Ki B These are the packages that would be merged, in order: Calculating dependencies... into the dependency graph, resulting in a slot conflict: dev-libs/icu:0 (dev-libs/icu-56.1:0/56::gentoo, ebuild scheduled for merge) pulled in by (no parents that aren't satisfied by other packages in this slot) (dev-libs/icu-55.1:0/55::gentoo, installed) pulled in by dev-libs/icu:0/55=[abi_x86_32(-),abi_x86_64(-)] required by (dev-qt/qtcore-4.8.7-r1:4/4::gentoo, installed) ^^^^^^ It may be possible to solve this problem by using to prevent one of those packages from being selected. ,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] (=dev-lang/python-exec-2:=[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)]) required by (sys-apps/portage-2.4.0:0/0::gentoo, installed) =dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_pypy(-)] required by (dev-python/ssl-fetch-0.3:0/0::gentoo, installed) =dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_pypy(-),-python_single_target_pypy3(-)] required by (dev-python/idna-2.0:0/0::gentoo, installed) =dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_pypy(-),-python_single_target_pypy3(-)] required by (virtual/python-ipaddress-1.0:0/0::gentoo, installed) =dev-lang/python-exec-2:=[python_targets_python2_7(-)? Multiple package instances within a single package slot have been pulled !!! ,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] (=dev-lang/python-exec-2:=[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)]) required by (app-editors/vim-7.4.712:0/0::gentoo, installed) dev-lang/python-exec:2 required by (dev-python/pygobject-2.28.6-r55:2/2::gentoo, installed) =dev-lang/python-exec-2:=[python_targets_pypy(-)? It can be either a file containing the content I mentioned, or a directory with separate files containing the same content.

I'm basically assuming most people will use it as a directory, but that might not be.

If such a conflict exists in the dependencies of two different packages, then those packages can not be installed simultaneously.

You may want to try a larger value of the --backtrack option, such as --backtrack=30, in order to see if that will solve this conflict automatically.

What is your exact error with [email protected] ~ $ sudo emerge -a riot-web * IMPORTANT: 3 config files in '/etc/portage' need updating.

* See the CONFIGURATION FILES and CONFIGURATION FILES UPDATE TOOLS * sections of the emerge man page to learn how to update config files.

For more information, see MASKED PACKAGES section in the emerge man page or refer to the Gentoo Handbook.